Автор Тема: нужен последний chrome  (Прочитано 6940 раз)

Оффлайн 1coba1

  • Постоялец
  • ***
  • Сообщений: 103
  • Карма: +1/-0
    • Просмотр профиля
    • E-mail
нужен последний chrome
« : 16 Март 2011, 21:07:57 »
добрый день, есть у кого-то последний chrome со всеми модулями встроенными.. ?

Оффлайн mistermo

  • Пользователь
  • **
  • Сообщений: 8
  • Карма: +0/-0
    • Просмотр профиля
    • E-mail
Re: нужен последний chrome
« Ответ #1 : 08 Август 2011, 02:11:31 »
http://www.slax.org/modules/4249/dl/google-chrome-12.0.742.112.lzm эт последний нет? хз, но должен работать. С оф сайта как никак. Но у меян по каким то причинам не работает!

Оффлайн edukra

  • Постоялец
  • ***
  • Сообщений: 197
  • Карма: +7/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #2 : 12 Август 2011, 16:56:08 »
Последняя версия хрома есть на сайте "Гугль" google-chrome-stable-13.0.782.107-94237
Но мне не удалось запустить её в слаксе. после установки всех зависимостей и обновления устаревших библиотек наткнулся на непонятную ошибку:
libc.so.6: version `GLIBC_2.11' not found (required by chrome)
После установки Glibc 2.11 ошибка не исчезла.

Оффлайн edukra

  • Постоялец
  • ***
  • Сообщений: 197
  • Карма: +7/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #3 : 12 Август 2011, 18:49:41 »
Наконец, после нескольких попыток мне все-таки удалось запустить хром
Для запуска нужны:
http://www.slax.org/modules/520/dl/liborbit2.lzm
http://www.slax.org/modules/517/dl/libgconf2-4.lzm
http://www.slax.org/modules/3748/dl/libpng-1.4.1.lzm
http://www.slax.org/modules/3997/dl/libz-1.2.5.lzm
http://www.slax.org/modules/3555/dl/libstdc-6-4.4.1.lzm
http://www.slax.org/modules/3468/dl/qt4-4.7.3.lzm
Также нужна библиотека libc версии 2.11, а на официальном сайте - только 2.10 есть поэтому её нужно взять из какого-нибудь свежего дистрибутива(я взял из альт линукса)
Следующие 2 модуля можно не скачивать, а взять нужные файлы из свежего дистрибутива firefox`а
http://www.slax.org/modules/4143/dl/mozilla-nss-3.12.3-i486-2alien.lzm
http://www.slax.org/modules/1328/dl/sqlite-3.6.6.2-1.lzm
если все это в 1 модуль собрать, то размер получится больше 60 мегабайт....

« Последнее редактирование: 12 Август 2011, 19:35:46 от edukra »

Оффлайн mistermo

  • Пользователь
  • **
  • Сообщений: 8
  • Карма: +0/-0
    • Просмотр профиля
    • E-mail
Re: нужен последний chrome
« Ответ #4 : 13 Август 2011, 01:04:54 »
так кто может, соберите плиз. Всем нужен хром)

Оффлайн novah

  • Глобальный модератор
  • Старожил
  • *****
  • Сообщений: 335
  • Карма: +2/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #5 : 13 Август 2011, 02:25:15 »
Угу, совершенно верно я задолбался эти библиотеки собирать  :D, может тем кому надо, попробуют porteus? Вроде поновее там все  :), просто последний хром требует последних библиотек, а их тянуть не хочется, тут все надо обновлять
ЗЫЖ qt4 вроде там не нужно, я тож запустил, но вроде без нее...
edukra, если то что ты написал правда, тогда я ваще не знаю зачем оно нужно, тогда огненный лис тоже подойдет так же, и еще и базу данных напихали, ваще крыша сьехала :D
Вот это я запускал https://dl.google.com/linux/direct/google-chrome-stable_current_i386.deb
Там вон кстати парень чото пилит, модули и все такое http://code.google.com/p/fidoslax/
« Последнее редактирование: 13 Август 2011, 02:40:22 от novah »

Оффлайн novah

  • Глобальный модератор
  • Старожил
  • *****
  • Сообщений: 335
  • Карма: +2/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #6 : 13 Август 2011, 02:43:36 »
так кто может, соберите плиз. Всем нужен хром)
А это, нуу, понимаешь, тут же у всех отпуски, как оно все закончится так и сделаем, ну я честно пробовал сделать но на второй день меня уже не хватило, в принципе это возможно, но чото муторно это все  ;D, если никто не подкинет, то тогда чуть подождать нада  :)

Оффлайн edukra

  • Постоялец
  • ***
  • Сообщений: 197
  • Карма: +7/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #7 : 13 Август 2011, 11:40:28 »
Вполне возможно, что qt4 не обязательно. Просто у меня уже стоял и хром ругнулся, что версия QT4 устарела. Вот я и скачал поновее. А вообще я брал хром в RPM формате. Попробую сегодня без qt4, если не получится - тогда попробую скачать в формате deb.

Оффлайн mistermo

  • Пользователь
  • **
  • Сообщений: 8
  • Карма: +0/-0
    • Просмотр профиля
    • E-mail
Re: нужен последний chrome
« Ответ #8 : 13 Август 2011, 14:46:14 »
мда, знал бы  я как собирать модули, сам бы собрал)

Оффлайн novah

  • Глобальный модератор
  • Старожил
  • *****
  • Сообщений: 335
  • Карма: +2/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #9 : 13 Август 2011, 16:20:38 »
Ну что там собирать? tgz2lzm, txz2lzm, deb2lzm, rpm2lzm. Грузишь из консоли, матюкается на библиотеки какието, качаешь библиотеки, на другие матюкается, качаешь, ну и тд пока не заработает  :)
Берем пакет стандартной слаквары в формате txz и в консоли набираем, предположим фаерфокс: txz2lzm fierfox(чивототам).txz  fierfox(чивототам).lzmПолучаем модуль, говорим activate fierfox(чивототам).lzm ну и проверяем работает или нет :)
« Последнее редактирование: 13 Август 2011, 16:26:28 от novah »

Оффлайн mistermo

  • Пользователь
  • **
  • Сообщений: 8
  • Карма: +0/-0
    • Просмотр профиля
    • E-mail
Re: нужен последний chrome
« Ответ #10 : 13 Август 2011, 19:00:50 »
я в этом нуб( токо подсел на slax

Оффлайн edukra

  • Постоялец
  • ***
  • Сообщений: 197
  • Карма: +7/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #11 : 13 Август 2011, 19:10:35 »
Ох уж эти устаревшие библиотеки... В общем надоели мне попытки запустить хром.
Вчера, добившись появления окна с сообщением, что не рекомендуется хром запускать из под рута, я подумал: если уж появилось окно - все нужное в сборе. Сегодня выяснилось, что это не так. После запуска хром выдал в консоль, что еще нужно обновить GTK и вывалился. А после обновления GTK - выдал в консоль штук 70 ошибок об устаревших библиотеках. При этом он наконец-то запустился, но ни на один сайт не заходит. Выдает, что невозможно подключиться к серверу.
Так, что у меня попытка запустить хром в слаксе завершилась провалом, а вот в портеусе запускается и работает отлично. Для этого нужно всего 2 дополнительных модуля: liborbit2 и libgconf2

Оффлайн novah

  • Глобальный модератор
  • Старожил
  • *****
  • Сообщений: 335
  • Карма: +2/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #12 : 15 Август 2011, 02:34:30 »
У меня то же самое получилось я имею в виду не запускается рутом, а кстати не пробовал запускать не из под рута? Кстати а что это за фишка такая из под рута не запускаемо? Может лечится както? И если пробовал в портеусе, то там что ты не рут?

Оффлайн Artpsiholog

  • Администратор
  • Постоялец
  • *****
  • Сообщений: 243
  • Карма: +2/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #13 : 15 Август 2011, 09:58:54 »
Цитировать
а что это за фишка такая из под рута не запускаемо?
Может быть в исходниках поискать что-то типа...
if [ "$USER" = 'root' ]; then
        echo 'Fuck you.'
        exit 1;
else
Yeahhh...
fi
exit 0;
Это на баше, конечно, но смысл, думаю, донёс.

Других вариантов, как запуск рута может быть предотвращён, у меня нет.

Ну и да, господа, а есть смысл запускать в стареньком (ведь уже стернький, согласитесь) слаксе последний хром?

P. S. Пакеты б в нём обновить все. Но это ж форк полноценный получится... Кто ж возьмётся-то.
« Последнее редактирование: 15 Август 2011, 10:01:41 от Artpsiholog »

Оффлайн edukra

  • Постоялец
  • ***
  • Сообщений: 197
  • Карма: +7/-0
    • Просмотр профиля
Re: нужен последний chrome
« Ответ #14 : 15 Август 2011, 20:10:33 »
если ему принудительно при запуске назначать другую папку с профилем, то запускается и из под рута. Например так:
./chrome --user-data-dir=/tmp/chrome